La fonction INDEX d’Excel

Syntaxe (version tableau)

INDEX(tableau; numéro_ligne; numéro_colonne)
Syntaxe (version de référence)

INDEX(référence, num_ligne; num_colonne; num_zone)
Définition.

Cette fonction utilise un index de ligne et/ou de colonne pour sélectionner une ou plusieurs valeurs d’un tableau (plusieurs cellules ou expressions connectées séparées par un point-virgule et mises entre accolades) ou d’une référence (qui peut contenir une ou plusieurs références à des zones rectangulaires) sur la base des entrées d’index.
Arguments (version tableau)
tableau (obligatoire). Doit être une plage de cellules ou une constante matricielle.
num_ligne (facultatif). Peut être omis si l’argument tableau ne comprend qu’une seule cellule. Cet argument doit être évalué à un entier positif et spécifie le numéro de la ligne contenant les valeurs avec lesquelles travailler.
num_colonne (facultatif). Une expression qui doit évaluer à un entier positif. Cet argument spécifie le numéro de la colonne qui contient les valeurs à choisir et peut être omis si la référence de tableau se compose d’une seule colonne.
Arguments (version de référence)
référence (obligatoire). Doit évaluer une référence à une ou plusieurs plages de cellules.
num_ligne et num_colonne (facultatif). Identique à la version tableau, mais ces arguments indiquent le numéro de la ligne ou de la colonne qui contient les valeurs à choisir, et par conséquent, ils n’ont pas à être évalués en nombres entiers positifs.
Si l’argument de référence se compose de plusieurs parties, ces parties sont numérotées dans l’ordre dans lequel elles sont saisies.
area_num (facultatif). Sélectionne une plage spécifiée dans l’argument de référence concernant l’ordre dans lequel les plages sont définies.
Contexte
Dans la version tableau, les arguments row_num et column_num vont généralement de 1 au nombre de lignes ou de colonnes dans la plage ou dans une liste de valeurs. Si la gamme se compose uniquement d’une seule ligne (colonne), l’argument row_num (column_num) peut être omis. Pour omettre l’argument row_num, entrez deux virgules. Si vous omettez plusieurs lignes, vous pouvez référencer la colonne spécifiée dans column_num avec une formule matricielle dans les cellules verticales. Il en va de même si vous souhaitez omettre plusieurs
Colonnes.
Si les arguments row_num et column_num dépassent la plage, vous obtiendrez le #REF! Erreur. La formule
=INDICE(B4:C6; 3; 2)
renvoie l’élément dans C6 (troisième ligne, deuxième colonne dans la plage B4:C6). De même, considérez les éléments suivants :
=INDICE({2;4;6;8}; 2; 1)
(Ce n’est pas une formule matricielle, vous devez donc entrer les accolades au lieu d’appuyer sur Ctrl+Maj+Entrée.)
L’argument {2;4;6;8} est reconnu comme colonne et la formule renvoie 4 (la deuxième ligne de la colonne).
Les constantes de tableau qui incluent plusieurs colonnes constituent une situation particulière, car les lignes sont séparées par des points-virgules et les colonnes sont séparées par des virgules. Par exemple, {11,12,13;21,22,23}
est reconnu comme la formule
=INDICE({11,12,13;21,22,23}; 2; 3)
renvoie 23 (deuxième ligne, troisième colonne).
Vous pouvez utiliser la fonction INDEX() dans une formule matricielle, comme illustré dans l’exemple suivant. Si vous entrez
{=INDICE({11,12,13;21,22,23}; 0; 3)}
ou
{=INDICE({11,12,13;21,22,23},,3)}
comme formule matricielle dans deux cellules verticales, la formule renvoie 13, 23. Si vous entrez
{=INDICE({11,12,13;21,22,23},2,0)}
ou
{=INDICE({11,12,13;21,22,23},2)}
en tant que formule matricielle dans trois cellules horizontales, la formule renvoie 21, 22, 23. Si la plage de destination est plus grande que la plage source, les cellules supplémentaires affichent l’erreur #N/A.
Dans la version de référence, le premier argument doit être une référence. Si vous souhaitez utiliser plusieurs plages, chaque plage doit être constituée de cellules contiguës. L’argument de référence pour plusieurs références séparées par des points-virgules doit être placé entre parenthèses pour garantir qu’Excel affecte correctement les arguments.
L’ordre des références dans l’argument est indiqué par un entier, commençant à 1, pour identifier la plage de cellules dans l’argument area_num. Les arguments row_num et column_num se comportent comme dans la version du tableau.
Si l’un des arguments row_num, column_num ou area_num dépasse la plage, la fonction renvoie le #REF! Erreur. La formule
=INDICE((B18:C20,E18:G19),3,2,1)
renvoie la référence à l’élément de la troisième ligne de la deuxième colonne de la première plage (C20).
INDEX() accepte les plages nommées dans l’argument de référence. Si vous entrez d’abord le nom pour la plage B18:C20 (en sélectionnant Noms définis/Définir le nom dans l’onglet Formules dans Excel 2007 ou Excel 2010 ou Insérer/Noms/Définir dans les versions antérieures) et le nom en second pour la plage E18 à G19, le formule
=INDICE((premier,deuxième),2,1,2)
renvoie une référence à la cellule de la deuxième ligne de la première colonne de la plage nommée deuxième : E19.
Vous pouvez également nommer toutes les cellules B18:C20,E18:G19 (dans cet ordre) avec le nom Both. alors la formule
=INDICE(les deux,2,3,2)
renvoie les informations de la troisième colonne de la deuxième ligne de la deuxième sous-zone : G19. Vous pouvez omettre l’argument row_num ou column_num ou les deux (en laissant l’espace entre les virgules vide) pour référencer des colonnes ou des lignes ou une plage entière. Dans ce cas, vous devez utiliser la formule comme tableau
formule ou vous obtiendrez la #VALEUR ! erreur à moins que la plage ne se compose d’une seule ligne ou colonne.

S’abonner
Notifier de
0 Commentaires
Inline Feedbacks
Voir tous les commentaires

Initiation à Excel

Fonctions Excel

Excel VBA

Macros VBA Utiles

Plus d'outils

Sur Facebook

Sur YouTube

0
Nous aimerions avoir votre avis, veuillez laisser un commentaire.x
()
x