UTILISER LA FONCTION “PRODUIT” POUR MULTIPLIER LES VALEURS CONDITIONNELLES

Dans cet exemple, les valeurs sont répertoriées dans les colonnes A et B. Excel doit calculer le produit de chaque valeur d’une ligne, mais uniquement si les deux valeurs existent. Si une ou les deux valeurs sont manquantes, le résultat est une cellule vide, comme indiqué dans la colonne C. Pour obtenir les résultats souhaités, utilisez la fonction PRODUIT en combinaison avec les fonctions SI et OU comme décrit ci-dessous.

Pour multiplier des valeurs conditionnelles :

  1. Dans les cellules A2:A10, entrez des nombres pour la valeur 1.
  2. Dans les cellules B2:B10, entrez des nombres pour la valeur 2.
  3. Sélectionnez les cellules C2:C10 et saisissez la formule suivante :

=SI(OU(A2=””;B2=””);” “;PRODUIT(A2;B2)).

  1. Appuyez sur <Ctrl+Entrée>.

FIGURE 

REMARQUE La formule suivante produit le même résultat : =SI(OU(A2=””;B2=””); ””; A2 * B2).

S’abonner
Notifier de
0 Commentaires
Inline Feedbacks
Voir tous les commentaires

Fonctions Excel

Macro VBA Utiles

Excel Pratique

Programmation VBA

Sur Facebook

Sur YouTube

0
Nous aimerions avoir votre avis, veuillez laisser un commentaire.x
()
x