UTILISER LA FONCTION TEXTE POUR EXTRAIRE LES PARTIES DE DATE DANS EXCEL

Une feuille de travail contient des valeurs de date dans la colonne A sous forme de texte qui ne peut pas être interprété par Excel comme des valeurs de date. Comme dans l’exemple précédent, le texte doit être extrait, mais le résultat doit être spécialement formaté comme indiqué dans la capture d’écran ci-dessous.

Pour extraire, combiner et afficher une date spécialement formatée :

  1. Sélectionnez les cellules B2:B10 et saisissez la formule suivante :

=TEXTE(DATE(DROITE(A2; 4); STXT(A2; 3 ;2); STXT(A2; 1; 2)); “AAAA-MM-JJ”).

  1. Appuyez sur <Ctrl+Entrée>.

FIGURE 

REMARQUE Tout d’abord, transférez les quatre derniers chiffres avec la fonction DROITE. Utilisez ensuite la fonction STXT deux fois pour obtenir les deux chiffres du mois et ceux du jour. Avec la fonction TEXTE, la date peut être formatée individuellement.

 

S’abonner
Notifier de
0 Commentaires
Inline Feedbacks
Voir tous les commentaires

Initiation à Excel

Fonctions Excel

Excel VBA

Macros VBA Utiles

Plus d'outils

Sur Facebook

Sur YouTube

0
Nous aimerions avoir votre avis, veuillez laisser un commentaire.x
()
x