Utiliser les fonctions TRANSPOSE et OU d’Excel pour déterminer les numéros en double dans une liste

Imaginez que vous ayez une longue liste de nombres et que votre tâche consiste à identifier tous les nombres qui se produisent plus d’une fois. Toutes les valeurs doivent être vérifiées pour voir si elles apparaissent plus d’une fois en utilisant les fonctions TRANSPOSE et OU. Ensuite, tous les nombres dupliqués doivent être ombrés à l’aide de la fonction NB.SI, qui est liée au formatage conditionnel.

Pour déterminer les numéros en double dans une liste :

  1. Dans les colonnes A et B, indiquez les numéros, dont certains sont répétés au moins une fois.
  2. Sélectionnez la cellule D2 et saisissez la formule matricielle suivante :

=OU(TRANSPOSE(A2:A11)=B2:B11).

  1. Appuyez sur <Ctrl+Maj+Entrée>.
  2. Sélectionnez les cellules A2:B11.
  3. Dans l’onglet Accueil, accédez à la barre Styles et cliquez sur Mise en forme conditionnelle.
  4. Choisissez Nouvelle règle.
  5. Dans la boîte de dialogue Sélectionner un type de règle, sélectionnez Utiliser une formule pour déterminer les cellules à formater.
  6. Dans la zone Modifier, saisissez la formule suivante :

=NB.SI($A$2:$B$11; A2)>1.

  1. Cliquez sur Format, sélectionnez une couleur dans l’onglet Remplissage et cliquez sur OK.
  2. Cliquez sur OK.

 

 

 

 

S’abonner
Notifier de
0 Commentaires
Inline Feedbacks
Voir tous les commentaires

Initiation à Excel

Fonctions Excel

Excel VBA

Macros VBA Utiles

Plus d'outils

Sur Facebook

Sur YouTube

0
Nous aimerions avoir votre avis, veuillez laisser un commentaire.x