Utilisez la fonction NB.SI d’Excel pour marquer automatiquement l’entrée en double

Parfois, une liste doit être vérifiée pour les entrées en double. Cet exemple crée une liste aléatoire, puis trouve toutes les valeurs en double et les marque. Utilisez la fonction NB.SI pour compter les nombres répétés dans une plage, puis utilisez cette fonction avec une mise en forme conditionnelle pour ombrager toutes les valeurs en double comme vous le souhaitez.

Pour marquer automatiquement les entrées en double :

  1. Sélectionnez la plage A1:D10.
  2. Tapez la formule suivante pour générer des nombres aléatoires de 1 à 300 :

= ALEA.ENTRE.BORNES(1; 300).

  1. Appuyez sur <Ctrl+Entrée>.
  2. Dans le menu Format, cliquez sur Mise en forme conditionnelle.
  3. Sélectionnez Formater uniquement les valeurs uniques ou en double ou utilisez la formule suivante dans l’option de formule pour définir les règles :

= NB.SI($A$1:$D$12; A1)>1.

  1. Cliquez sur Formater.
  2. Dans l’onglet Motifs, choisissez une couleur et cliquez sur OK.
  3. Cliquez sur OK.

 

FIGURE 

 

 

 

REMARQUE Appuyez sur <F9> pour recalculer et générer de nouveaux nombres aléatoires pour la plage.

 

 

 

S’abonner
Notifier de
0 Commentaires
Inline Feedbacks
Voir tous les commentaires

Initiation à Excel

Fonctions Excel

Excel VBA

Macros VBA Utiles

Plus d'outils

Sur Facebook

Sur YouTube

0
Nous aimerions avoir votre avis, veuillez laisser un commentaire.x