UTILISEZ LA FONCTION SIGNE POUR VÉRIFIER LE SIGNE D’UN NOMBRE

Excel fournit la fonction SIGN pour vérifier le signe d’un nombre. Cette fonction renvoie 1 si le nombre est positif, 0 si le nombre est 0 et –1 si le nombre est négatif. Si l’utilisateur entre du texte au lieu d’un nombre, la fonction SIGN renvoie le code d’erreur #VALUE!.

SIGNE (nombre).

nombre : n’importe quel nombre réel.

Pour vérifier le signe d’un nombre :

  1. Dans les cellules A2:A10, répertoriez les numéros ou le texte.
  2. Sélectionnez les cellules B2:B10 et saisissez la formule suivante :

=SI(ESTERREUR(SIGNE(A2)); “”; SIGNE(A2)).

  1. Appuyez sur <Ctrl+Entrée>.

FIGURE 6–40

REMARQUE Le même résultat pour les valeurs numériques peut également être généré en combinant SI

les fonctions. Utilisez cette formule :

=SI(A1>0;1;SI(A2<0;–1;0)).

 

S’abonner
Notifier de
0 Commentaires
Inline Feedbacks
Voir tous les commentaires

Initiation à Excel

Fonctions Excel

Excel VBA

Macros VBA Utiles

Plus d'outils

Sur Facebook

Sur YouTube

0
Nous aimerions avoir votre avis, veuillez laisser un commentaire.x
()
x